Norway


Although I believe this is harmless, warnings quite irk me. So I’m using a very version of TwilioChatClient together with TwilioClient. These two specific versions are what Twilio have been using in their sample projects.

Anyways, the warning when installing / updating pods:

[!] Found multiple specifications for TwilioChatClient (1.0.9):
– /Users/XXX/.cocoapods/repos/master/Specs/7/d/e/TwilioChatClient/1.0.9/TwilioChatClient.podspec.json
– /Users/XXX/.cocoapods/repos/twilio/TwilioChatClient/1.0.9/TwilioChatClient.podspec

[!] Found multiple specifications for TwilioChatClient (1.0.8):
– /Users/XXX/.cocoapods/repos/master/Specs/7/d/e/TwilioChatClient/1.0.8/TwilioChatClient.podspec.json
– /Users/XXX/.cocoapods/repos/twilio/TwilioChatClient/1.0.8/TwilioChatClient.podspec

[!] Found multiple specifications for TwilioChatClient (1.0.7):
– /Users/XXX/.cocoapods/repos/master/Specs/7/d/e/TwilioChatClient/1.0.7/TwilioChatClient.podspec.json
– /Users/XXX/.cocoapods/repos/twilio/TwilioChatClient/1.0.7/TwilioChatClient.podspec

[!] Found multiple specifications for TwilioChatClient (1.0.6):
– /Users/XXX/.cocoapods/repos/master/Specs/7/d/e/TwilioChatClient/1.0.6/TwilioChatClient.podspec.json
– /Users/XXX/.cocoapods/repos/twilio/TwilioChatClient/1.0.6/TwilioChatClient.podspec

[!] Found multiple specifications for TwilioChatClient (1.0.5):
– /Users/XXX/.cocoapods/repos/master/Specs/7/d/e/TwilioChatClient/1.0.5/TwilioChatClient.podspec.json
– /Users/XXX/.cocoapods/repos/twilio/TwilioChatClient/1.0.5/TwilioChatClient.podspec

[!] Found multiple specifications for TwilioChatClient (1.0.4):
– /Users/XXX/.cocoapods/repos/master/Specs/7/d/e/TwilioChatClient/1.0.4/TwilioChatClient.podspec.json
– /Users/XXX/.cocoapods/repos/twilio/TwilioChatClient/1.0.4/TwilioChatClient.podspec

My podfile:

project 'Proj/Proj.xcodeproj'

 'https://github.com/CocoaPods/Specs'
 'https://github.com/twilio/cocoapod-specs'

platform :, '.0'
use_frameworks!

  target 'Proj' do

     'TwilioClient', '~>1.2'     # Twilio Call Framework
     'TwilioChatClient', '1.0.4' # Twilio Chat Framework


    target 'MobileMedTests' do
        inherit! :search_paths
    end

    post_install do |installer|
        installer.pods_project.targets.each do |target|
            target.build_configurations.each do |config|
                config.build_settings['SWIFT_VERSION'] = '4.0'
            end
        end
    end

  end

  target 'ProjUITests' do

  end

I think specifying two kinds of sources (which are both necessary) causes these warnings. Is there a way to put the specific source right beside the pod?



Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here